[SOLVED] J-Trace Pro v2 with NXP i.MX RT1060

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Trace Pro v2 with NXP i.MX RT1060

    Hi guys,

    We recently purchased a J-Trace Pro v2 for use in a project involving an NXP i.MX 1060 (namely the MIMXRT1060-EVK) and we're running into some difficulties in configuring the debugger alongside Keil MDK.

    We're running into the following issues:
    • Unable to load code straight into and run from SRAM (receive an error message that no flash algorithm is available).
    • We have been able to get QSPI to load and boot but strangely we sometimes have to connect to the device first with J-Link Commander otherwise we receive the error that the AIRCR can not be read.
    • Although we've been able to get SWO trace working (confirmed by sending over ITM characters), we're unable to use Keil's Logic or System Analyser to track changes in variables/state in real-time.
    Has anyone had experience with the NXP i.MX RT platform and is able to offer up any solutions/suggestions/best-practises to the points above? In particular we are very eager to resolve the last point as it's critical to our project.

    Many thanks
  • Hello,

    We received your inquiry through the ticket system as well.
    Please try to keep you inquires to one channels to make sure no information gets lost.
    This thread will be closed now.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.