[SOLVED] J-LINK EDU - weird VTarget reading

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-LINK EDU - weird VTarget reading

    Please, ignore this thread (or delete if possible :D), I have a 10pin connector in this board and I made a stupid connection with jump wires, thus I got disoriented and connected the wrong side!

    I have designed a board with an STM32F031F6 (TSOP20) part and I am trying to use my J-LINK EDU to flash and debug. Unfortunately it reads a VTarget of 0.472V although I checked that I get 3.26V out on the Vref pin (pin 1 Vref and I used pin 4 for ground in the 20-pin header). I used another older board that I had designed (with JTAG though, not SWD) and there seems to be working fine (it reads the 3.3V). I am using an SPX3819M5-L-3-3 voltage regulator and it only powers the microcontroller, a LED as a power indicator and a RS-485 tranceiver chip, thus it is supposed to be able to cope with these loads. Unfortunately I don't have an oscilloscope, so I cannot confirm that there is not a ripple voltage on the 3.3V regulator, but a 0.472V value would suggest a very big ripple and I am sure that the measured 3.26V is fine. Any suggestions? Can I for example bypass the VTarget and set it explicitly?


    The post was edited 1 time, last by gmor ().