[SOLVED] How to disable Linux JLinkRTTClient[Exe] input echo?

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] How to disable Linux JLinkRTTClient[Exe] input echo?

    Hi there,

    When using JLinkRTTClient[Exe] (not sure if Exe/non-Exe suffixed is not to be used), I seem to get input characters echoed, no matter what I do.

    I usually run it in an xterm window, doing stty -echo -echonl -ctlecho -echoprt beforehand, but the program itself seems to do its own echo anyway.

    That does not happen if I run PuTTY with echo forced off.

    Seems that JLinkRTTClient does not have any command line options about that, and JLinkExe does not have anything about this either.

    Running on Fedora Linux v28, with JLink 6.34h

    Regards

    The post was edited 1 time, last by david0might ().

  • Hello,

    Thank you for your inquiry.
    Disabling echo is currently not implemented as the RTTClient is a pure console application so our customers expect echo for input verification.
    However we will discuss it internally if this feature will be added but no promises.
    Alternatively you could use our J-Link SDK and write your own version of RTTClient with echo off option: segger.com/products/debug-prob…nk/technology/j-link-sdk/

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/