[SOLVED] nRF52840_xxAA RAM code error when erasing

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] nRF52840_xxAA RAM code error when erasing

    I am currently using Jlink V634f on a custom board that uses the nRF52840_xxAA part.

    We are running into the following issue when trying to erase the device.

    Source Code

    1. J-Link>erase
    2. Erasing device (nRF52840_xxAA)...
    3. J-Link: Flash download: Total time needed: 40.869s (Prepare: 0.023s, Compare: 0.000s, Erase: 20.839s, Program: 0.000s, Verify: 0.000s, Restore: 20.005s)
    4. ****** Error: Timeout while erasing sectors, RAMCode did not respond in time. (PC = 0x00000000, CPSR = 0x00000000, LR = 0x01000003)!
    5. Erasing done.
    6. J-Link>
    This issue appears to be more prevalent when erasing a device after having programmed it and halted. For example when following the next steps we get an error about 80% of the time

    1. Start Jlink and connect to the device
    2. halt the device
    3. erase
    4 program
    5 reset and halt
    6 erase

    During step #6 the error shown above is displayed after the progress bar gets stuck ~98% of progress

    Trying to erase once more appears to complete successfully.

    has anyone experienced this issue? is this a known bug and are there any workarounds?

  • Hello,

    Thank you for your inquiry.
    We received your inquiry per e-mail as well. To make sure not information gets lost through multiple communication channels this thread will be closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.