Layer[1] displays in GUICC_M8888I but not M565

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Layer[1] displays in GUICC_M8888I but not M565


      I've been using two layers on STM32F4 with the configuration for both layers

      Layers are in SDRAM, each in its own bank. Screen is 800x480.

      My LTDC frame refresh is low using this configuration so I tried a change to this

      However, now my background layer does not show. The primary layer shows correctly. I have not changed any other configuration, just the ColorConversion and DisplayDriver. I am using the driver template stm32f4x9i_eval_mb1046.c

      I've tried a number of changes (different conversions and drivers) but have ran out of thoughts on what to try.

      I can change to soft-layer and could even live with the low refresh rate but am wondering if you have any advice for where I could look or what I could change?

    • Hi,

      How big is the is the second layer?

      If the layer with color conversion M565 is covering the other layer completely, the background layer can't be visible. The color conversion GUICC_M565 doesn't support transparency. You could use GUICC_M1555I, there you will have one bit indicating transparent pixels and 15 bit for color information.

    • Hi Sven,

      Sorry for the delay in responding. I have been travelling.

      Both layers are the same size (800x480). I understand the issue of transparency when the emWin library is stacking objects or layers and will have a look at this again. Maybe I am misunderstanding the use of VRAM switching for layers in the mb1046-style driver for the 32F429I as I did not think transparency is an issue for the two hardware (vram) layers implemented. I thought they got painted no-matter-what as the vram is RGB info only and no transparency. So, more testing.

      To be honest I stopped looking at this as I tracked down the slow frame paint issue to another issue. I am posting a Q on this separately,