[SOLVED] j-link pro does not work with the Microchip PIC32MZ2064DAB176

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] j-link pro does not work with the Microchip PIC32MZ2064DAB176

    The j-link pro does not work with the PIC32MZ2064DAB176. The message below is displayed in MPLabX.

    Connecting to JLink Probe...
    Connection Failed
    MPLABComm returned an error code of -114, Invalid selection.

    J-Link does work for the PIC32MZ2048EFM144 processor. The error message can be displayed by creating a new 32-bit MPLAB Harmony Project in MPLabX using the PIC32MZ2064DAB176 processor, and clicking the "Make and program device" button (green down arrow).

    My setup uses MPLabX version 5.00, version 1.3.20 of the SEGGER JLink Probe MPLAB X Tool Plug-in, j-link hardware version 4.00 and j-link firmware version compiled Aug 7, 2018
  • Hello,

    Thank you for your inquiry.
    The PIC32MZ2064 is currently not officially supported: segger.com/downloads/supported-devices.php
    We have an eval board in house with that chip so Flashing support might be added within this year. But we have no fixed schedule due to low demand for this device.

    Generally debug support for various PIC32 devices in MPLAB is handled through Microchip. So we suggest contacting Microchip in that regard.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/