[SOLVED] NUCLEO interrupts problem

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] NUCLEO interrupts problem

    This is my first post on this forum, so Hi everyone

    Now, to the core...
    I'm having a really strange behaviour with Embedded Studio on my nucleo boards, previously i was developing with eclipse/crossworks and everything worked fine, but same projects compilled and uploaded with Embedded studio are causing hard fault when interrupt occures. After hours of trying to figure this out I gave up, and I need to ask for some help.
    Are U Guys using nucleo with Embedded Studio?
    ps. I'm creating new project with CubeMx, then I'm importing it to IDE.
  • Hello,

    Thank you for your inquiry.
    Which version of Embedded Studio are you using?
    The latest version 3.50 has a project importer for AC6/STM32 Workbench projects which can be created in CubeMX and then imported to Embedded Studio.
    Do the same issues appear if you import it with the new project importer?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/