[SOLVED] LPC804 not found ...

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] LPC804 not found ...

    Greetings.

    I'm trying to set up with an NXP OM40001 development kit. It's an LPC804 Cortex M0. User guide here: https://www.nxp.com/docs/en/user-guide/UM11083.pdf

    The on-board SWD is disabled as per instructions for J1.

    Below is the output from J-Link. Any ideas on what to try next?

    TAIA

    Source Code

    1. J-Link>connect ?
    2. Device "LPC804" selected.
    3. Connecting to target via JTAG
    4. Could not measure total IR len. TDO is constant high.
    5. Could not measure total IR len. TDO is constant high.
    6. TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
    7. TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
    8. Cannot connect to target.
    9. J-Link>
    Display All
  • Hello,

    Thank you for your inquiry.
    The specified eval board does not support JTAG. SWD must be used instead.
    A successful connection using an external J-Link can be seen in the attached picture.

    Best regards,
    Nino
    Images
    • Capture.PNG

      32.2 kB, 677×594, viewed 19 times
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    The following contact form can be used for this: Contact Us