[ABANDONED] J-Link RTT Client can't connet to RTT Server

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] J-Link RTT Client can't connet to RTT Server


    I've been using Segger utilities on Windows for some time but few days ago I decided to switch to Linux and this is where problems started to arise. I'm using Eclipse CDT with ARM plugin. With this setup i am able to debug/program and step trough code without any problems. What bothers me is fact that RTT Client can't connect to my debug session, it never change status to 'Connected'. It constantly keep saying "###RTT Client: Connecting to J-Link RTT Server via localhost:19021 ..." and that's all :( I'm pretty sure that project configuration is valid because exactly the same project works on Windows machine without any problems.

    I also tried to connect manually via JLinkExe but that didn't change anything, below are logs:
    Connecting to target via SWD
    Found SW-DP with ID 0x2BA01477
    Found SW-DP with ID 0x2BA01477
    Scanning AP map to find all available APs
    AP[1]: Stopped AP scan as end of AP map has been reached
    AP[0]: AHB-AP (IDR: 0x24770011)
    Iterating through AP map to find AHB-AP to use
    AP[0]: Core found
    AP[0]: AHB-AP ROM base: 0xE00FF000
    CPUID register: 0x410FC241. Implementer code: 0x41 (ARM)
    Found Cortex-M4 r0p1, Little endian.
    FPUnit: 6 code (BP) slots and 2 literal slots
    CoreSight components:
    ROMTbl[0] @ E00FF000
    ROMTbl[0][0]: E000E000, CID: B105E00D, PID: 000BB00C SCS-M7
    ROMTbl[0][1]: E0001000, CID: B105E00D, PID: 003BB002 DWT
    ROMTbl[0][2]: E0002000, CID: B105E00D, PID: 002BB003 FPB
    ROMTbl[0][3]: E0000000, CID: B105E00D, PID: 003BB001 ITM
    ROMTbl[0][4]: E0040000, CID: B105900D, PID: 000BB9A1 TPIU
    ROMTbl[0][5]: E0041000, CID: B105900D, PID: 000BB925 ETM
    Cortex-M4 identified.

    Any ideas where is the problem ?

    Best Regards
    Mateusz Piesta
  • Hello Mateusz,

    Thank you for your inquiry.
    We tried to reproduce the issue using Embedded Studio and RTT Client under Ubuntu LTS 16.04 and everything was working as expected.
    Did you use the latest J-Link software version?
    Does it work if you use Embedded Studio or Ozone?

    Best regards,

    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/