[SOLVED] SystemView crash in Ubuntu

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SystemView crash in Ubuntu

    I'm trying to use SystemView with Zephyr running on the Cortex M4 CPU inside the i.MX7D SoC, but it crashes when I start the recording.

    Host: Ubuntu 16.04.4 LTS
    J-Link Commander: V6.32d
    Systemview: V2.52a
    Debugger: J-Link BASE

    Target Hardware: Toradex Colibri i.MX7D, MCIMX7D5_M4

    Steps to reproduce:
    1. Stop at u-boot command prompt
    2. Run JLinkExe
    3. Load and Run (via u-boot) Zephyr Systemview Sample app
    4. Execute SystemView app
    5. Start Recording with: USB, MCIMX7D5_M4, JTAG, 4000, -1, -1, Address, 0x200017d0

    JLinkExe command line output:

    SystemView command line output:
  • Hello,

    Thank you for your inquiry.
    A crash of SystemView was not reproducible on Ubuntu when recording an example embOS application on a Cortex-M4 target device.
    The crash most likely gets provoked either due to incorrect u-boot config or incorrect SystemView implementation in the Zephyr sources.
    Please understand that we can't offer support for issues resulting from third party applications that are not officially supported.
    We recommend to get in touch with u-boot and Zephyr support instead.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.