[SOLVED] nRF52 board startup issue

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] nRF52 board startup issue

    I am trying to "re-purpose" a third party nRF52 based product board.
    I am using the Nordic nRF52 SDK ver 15.0 and Embedded Studio.
    I can program the board using the SWDIO/SWCLK interface with Embedded Studio and J-Link.

    There is a problem in that the board will not break at "main" upon starting the Embedded Studio debugger.
    This only occurs when a SOFTDEVICE is used (ie. any BLE based code).
    Code that does not use the SOFTDEVICE breaks at "main" and then starts and runs correctly.

    Does anyone know of certain "startup" code that may need to be modified to work with the SOFTDEVICE?
    Using Ozone Debugger, the code will break at "main" on startup, but it hangs upon execution of the BLE initialization.


    The post was edited 2 times, last by jk2940 ().

  • Interesting...
    I tried "Erase All" from the "Target" menu in Embedded Studio and re-programmed the device, now it seems to work normally.
    Perhaps it had never really downloaded the SOFTDEVICE with the normal "Build" and "Debug" commands.
    Your tip led me to that jmag999. Thanks.
    Cool. Now I just need to debug the accelerometer I2C interface.