[SOLVED] SES missing header files

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SES missing header files

    Hi, I have following issue and need some help.
    I am using SEGGER Embedded studio for ARM Release 3.4 build 2018052200 36079 with latest nordicc's nRF_SDK_for_Thread_v0.11.0_84a130f on window 10 (64).

    I can compile <Thread SDK>/examples/thread/experimental/cli/usb without any errors BUT When I run it by pressing <Go command> on SES studio the File explorer window pops up, indicating "missing file". Add or remove for future. It shows up for several files. Which some o these file don't even exists.

    Upon search i found following post "Debugging OpenThread example with Segger"
    Per this post it indicates there are some issues with the latest SES development environment and suggest ignoring these messages as these source file are not needed for already compiled libraries.
    I was able to follow this and run the program. is this the right way?
  • Hello,

    Thank you for your inquiry.
    According to the Nordic SDK release notes the SDK has been tested with Embedded Studio V3.34. Other versions might need slight modifications. As the SDK is maintained by Nordic we suggest getting in contact with Nordic Semi support in that regards.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.