[SOLVED] RTT trace in tickless mode of FreeRTOS

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT trace in tickless mode of FreeRTOS

    I run FreeRTOS 10.01 on stm32l476. A sequence number is printed out from 1 task every 100ms.
    The trace on RTT console in embedded studio is like:
    0, 1, 2, 3, 4, 5, 6.....

    If I enable configUSE_TICKLESS_IDLE, The trace becomes incorrect.
    It could be like:
    0, 1, 2, 0, 1, 2, 3, 4, 0, 1, 2....

    I also output the number to UART and it increases correctly.

    I am wondering if there is a solution for it?

    The post was edited 1 time, last by blanc ().

  • Hello,

    Thank you for your inquiry.

    blanc wrote:

    It seems like a known issue in stm32 chip
    Correct. Unfortunately most ST devices do not allow memory access during sleep modes.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well: segger.com/ticket/