[SOLVED] J-LINK COM Port on Nordic PCA10040 Eval board - Connection Error

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-LINK COM Port on Nordic PCA10040 Eval board - Connection Error

    I have a Nordic PCA10040 (dev kit for the NRF53832) which has an integrated J-LINK. When I connect to the PC there is also a JLINK CDC UART Port. It appears that the device has enumerated correctly.

    When I try to connect to the port via putty I get an error that I cannot connect (picture attached).

    I was able to connect to this board via Segger Embedded Studio, load code, debug, etc.

    I have also tried to connect to the com port via a Python Script provide by nordic which give as "permission denied" error when I attempt to connect.

    I tried:

    Testarting the machine
    Cycling the USB cable
    Reinstalling the CDC driver.

    Any ideas of how to fix the problem?
    Images
    • jlink.png

      146.4 kB, 921×771, viewed 63 times
  • Hello,

    Thank you for your inquiry.
    We are not aware of any issues with the J-Link OB and VCOM on this particular eval board.
    Our recommendation is to contact Nordic Semi Support in that regard as they implemented the eval board hardware.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    The following contact form can be used for this: Contact Us