[SOLVED] LAN Issue on SAMA5D3 with embOS

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] LAN Issue on SAMA5D3 with embOS

    We are using SAMA5D3xek board. We are using embOS 4.34.1 and IAR 8.20 IDE. In LAN no packets are being received by the DMA (Ownership bit in receive buffer descriptor is always zero) if the we integrate (initializing kernel or hardware) the embOS into our project. We had to change the selected target as none from SAMA5d35 in project options, then only the LAN is working fine (with integrated embOS). We would appreciate if you could help us find the issue.
  • Hello Arul,

    it should not be necessary to change the selected target.
    Did you update the MMU table according to your device/hardware?

    Are you using one of our BSPs or did you create it on your own?
    embOS ARM IAR comes with board support packages for various SAMA4D3x boards.

    Best regards,
  • Hello,
    Thanks for your response. We are using the BSP provided by you. In fact we have just added the code to existing startup project given by you. In linker file we have just added the extra memory region for region_dma_nocache, other than this we haven`t changed anything in the base project.