No breakpoints not hit, but halting shows right $pc -- Reopened

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • No breakpoints not hit, but halting shows right $pc -- Reopened

    Please see my previous thread here. Sorry I had to travel for business for a while.

    [ABANDONED] No breakpoints not hit, but halting shows right $pc

    jhuels20 wrote:

    I've been dealing with an issue for a week or two now where I can't get any of my breakpoints to work. Here is what I'm using:

    - JLink Plus
    - JLink_V622c
    - LPC1857
    - JTAG
    - gcc-arm-none-eabi 4.9

    I've tried various debugging tools (eclipce MCU, VisualGDB, command
    line) and setups and no breakpoints are being hit. I have tried
    hardware, software (program not in RAM anyways), and flash breakpoints. I
    can tell the program is running because halting it will show a valid
    program counter and the symbols associated with it.

    I would share a log but it basically looks all good and just says "Starting target CPU" then nothing is hit.

    The only anomaly about my system is that there is a low-level bootloader
    that I do not have the source-code too (provided by contractor). This
    code has a "bkpt #0" instruction that IS being hit before main. After
    this, I am forced to "stepi" ("continue" takes back to same spot, I
    think this is known issue), and then continue. My program code executes
    as normal but no breakpoints are hit. I can view all registers,step
    instruction to instruction, halt, continue.

    Let me know what other information could help solve this. Thanks!

    Here is the log file that was requested:

    I'm still having the same issue as mentioned in my previous post, nothing has changed.

    Thanks for your help!
  • Hello Josh,

    Thank you for your inquiry.
    Could you answer the questions Leon asked?

    SEGGER - Leon wrote:

    For my understanding:
    When only using HW BPs, they are also not hit?
    Or is it specifically to SW BPs that only these are not hit?
    What about if you are debugging in internal flash? Do breakpoints work there, or do they also not work?

    Can you please give the following a try?:
    Leave your VisualGDB project as it is and install SEGGER Ozone in parallel.
    Now, instead of starting your debug session via VisualGDB etc., start it with Ozone.
    Do breakpoint work there?
    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support system can be used as well:
  • Both software and hardware breakpoints are not hit.
    I am not able to hit breakpoints in internal flash either.
    I've tried debugging with Ozone. Please see my Ozone log pastebin link above.

    Note - I can still halt execution with the pause button. Just breakpoints don't work (hard to debug without breakpoints :P).

  • Anyone have ideas on how to debug this further? Is there any more information I can gather that can help diagnose the issue?

    It seems I'm lacking an actual error code or useful message. The breakpoints say they are being made successfully, but then they are never hit. I know for a fact these areas of the code are being run. I've set them in the lowest layers of our RTOS without success. :(