[ABANDONED] Watch variables not updated in Ozone

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Watch variables not updated in Ozone

    I have V2.56r running on 64-bit Windows 7.

    The watch expressions are not updated unless I enter them with a right-click.
    If I enter them into the field with the black arrow, there is unreliable update. It might update a couple of times, then turns itself off. But mainly it stays off.

    Similar to this post: [SOLVED] [Ozone] 2.56M Possible regression with Variable Refresh

    The above post says problem solved, but I see the same problems.
  • Hello,

    Thank you for your inquiry.
    We tried to reproduce the issue with a simple example project and a ST eval board. In our setup the watched data was updating as expected.
    What target device are you trying to debug?
    Is it on an eval board or custom hardware?
    What is the S/N of the J-Link/J-Trace you are using?
    Could you provide an example project for Ozone where this issue is reproducible with reproduction steps?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.