[SOLVED] Replace button is grayed out in Segger studio for windows

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Replace button is grayed out in Segger studio for windows

    Very newbie question, so, sorry.

    I am starting to use SES 3.40 in windows, away from Keil, with a Nordic project.

    The Find and Replace works fine in the same document, but if I do it for Replace in Files (Ctrl-Alt-F), it will find all the references, but the replace button is grayed out.
    Already tried to see if it is an option in Options, but no luck.

    Anyone can tell me what I am doing wrong?
  • Hello,

    Thank you for your inquiry.
    In this case the documentation is not accurate. It will be updated accordingly.
    Find & Replace can only be used for files that are open in the editor.
    However you can use View->References to replace expressions on project level.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.