Bug in MULTIEDIT_AddText - no inserting Text after setting cursor -

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Bug in MULTIEDIT_AddText - no inserting Text after setting cursor -


      I have a problem using the MULTIEDIT_AddText.
      I use a Window with one MULTIEDIT object and many buttons as keypad for text-input on a touch-display. I add only one Character to the edit-object by click on one button using MULTIEDIT_AddText-function.
      The strait typing of characters works fine. But if set the cursor to another position into the string in many cases the library runs into an hardfault-exception. It mainly works if I set the cursor only one ore two characters behind the end of the string. In this cases I can insert characters. But if I have a string of - for example - about 16 characters and I set the cursor to the second character the lib crashes.

      I enable the insert-mode for the MULTIEDIT object.

      Does anyone have the same issue?

      The post was edited 1 time, last by bastl: I solved this issue on my own. The reason of this behavior was the __rt_memmove_v6 routine. This function contains a LDRPL assembler-command which is obviously not supported by Cortex-M7 controllers. Using micro-lib for my STM32F777-project solved this problem because the rt_memmove_v6 was never linked. ().