[SOLVED] Embedded Studio breaks Ubuntu Bionic's Gnome Setup when installed with restrictive default umask

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Embedded Studio breaks Ubuntu Bionic's Gnome Setup when installed with restrictive default umask

    Hi emStudio user community,
    when installing Embedded Studio on Linux (eg. with sudo or logged in as root) then the files are being installed with the standard sudo/root umask. This means that files are potentially installed with the wrong permissions, e.g. non world-readable. As the installer installs e.g. .desktop-files in the global applications folder, gnome-software (and other gnome tools) may be unable to read these files. This can corrupt gnome cache state. This is probably an interaction of invalid permissions and some less-then-resilient behavior of the GNOME desktop when presented with read-protected files on its scan paths.

    Ubuntu Bionic (18.04 LTS) seems to be specifically at risk as the default of umask_override seems to have changed from true to false since 16.04 LTS (at least on my machine...).

    The culprit is Embedded Studio, though, as the installer MUST make sure (by either setting rights explicitly or by checking/setting the umask beforehand) that files installed into system folders follow the permission conventions of the OS.

    In my case the MIME-configuration was corrupted which made GNOME lose all its access to icons (and all other MIME-identified files) which again completely broke the GNOME session.

    Steps to reproduce:
    * Set your user's umask to e.g. 0007
    * Use sudo without umask_override setting to install embedded studio on Ubuntu Bionic
    * Check that emStudio files are installed w/o world read rights
    * Continue to run GNOME until it tries to access any MIME resource (icons, configurations, ...), e.g. when opening new windows and crashes. ;)

    For those having similar problems:
    * apt install -f --reinstall all packages related to gnome session, ubuntu gnome plugins (dash, appindicator), pixbuf, mime types solved the problem in my case
    Don't know which were the exact package as I had to try several before I got my installation to work again

    Kind regards,

  • Hello Florian,

    Thank you for your inquiry.
    A fix for the reported issue has been implemented for the next release version which should we available sometime next week.
    Sorry for any inconveniences caused.

    To stay up to date with Embedded Studio releases you can subscribe to our notification list: segger.com/notification/subscribe.php?prodid=196

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/