[SOLVED] problem getting RTT working with STM32H743ZI and Ultra+

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] problem getting RTT working with STM32H743ZI and Ultra+

    I'm trying to get RTT working on an STM32H743ZI and it doesn't log to terminal window and I can't get the J-Link RTT viewer to find the RTT control block in my CPU memory.

    I'm using J-Link V6.22f with an Ultra+

    I first tried to call SEGGER_RTT_WriteString, which setup the signature block. I connected RTT viewer, and log another SEGGER_RTT_WriteString, but no output to the Terminal window.

    The menu Logging / Channel Infos says "RTT control block not found on target, yet."

    I manually use J-Mem to find the RTT control block at 0x200196a4. I disconnect the RTT viewer and reconnect, but this time specifying the RTT control block at this memory. It connects properly, but the "Logging / Channel Infos" says the same thing and no logging goes to the terminal window.


    Thanks...Keith Rhodes
  • Hello,

    Great to hear that you are up and running again.
    Generally we recommend using the latest J-Link software to have all new features and benefits of our regularly updated software.
    We will consider this thread as solved now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/