[SOLVED] [Ozone] Function pointer variables don't show function name

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] [Ozone] Function pointer variables don't show function name

    When there is a function pointer inside a structure and the structure is displayed in the watch or locals window, the content of the variable is shown in hex and does not give the name of the function that is pointed to. Ideally Ozone would say which function is pointed to.
    Observed for ARM Thumb.
  • Hello,

    Thank you for your inquiry.
    This is currently intended behaviour, we will however take this as feedback and will discussed in our next developer meeting.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/