[SOLVED] Loading FreeRTOS plugin (*.so) with JLinkGDBServer

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Loading FreeRTOS plugin (*.so) with JLinkGDBServer

    I'm trying to load the FreeRTOS pluing with the JLink GDB server. Using command:

    JLinkGDBServerCLExe -jlinkscriptfile myscipt -if jtag -device Cortex-M4 -endian little -speed 1000 -rtos GDBServer/RTOSPlugin_FreeRTOS.so

    I don't see any confirmation of the plugin being loaded.
    I *think*, there should be a trace coming with the rest of usual output, Loading RTOS plugin: %s...

    What am I doing wrong?

    I tried full path to the *.so too, no luck. I also don't get any error / warning trying to pass bogus plugin path/name, as in -rtos blabla.

    - EDIT -

    Looks like it's delayed load until GDB client connects
    Loading RTOS plugin: /opt/SEGGER/JLink_V630f/GDBServer/RTOSPlugin_FreeRTOS.so...
    RTOS plugin (v1.0) loaded successfully
    RTOS plugin initialized successfully.

    The post was edited 2 times, last by v01d ().