[SOLVED] SES + nrF SDK 14.2 : "stray # in program " error at compilation

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SES + nrF SDK 14.2 : "stray # in program " error at compilation

    Hi guys,

    I am working on a nrF52832 project and want to use SES since there is a license agreement with nordic based projects.

    I am using freertos from nordic SDK 14.2, and I have an error when compiling "port.c" from the freertos driver.

    The file "port.c" contains some assembly code. For some reason, Embedded studio and GCC can't compile the file and report the following errors :

    stray "#" in program

    Do you have any idea what I can do to fix this issue ?

    Thank you,
    Best regards
    Yves
  • Hello,

    Great to hear that you are up and running again.
    We will consider this thread as solved now.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    Alternatively our support ticketing system can be used as well: segger.com/ticket/