[SOLVED] JLink GDB Server: WARNING: Failed to read memory @ address 0x10000000 after halting the MCU

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLink GDB Server: WARNING: Failed to read memory @ address 0x10000000 after halting the MCU

    Dear all,

    I am writting the bare metal code firmware and drivers for one custom board based on iMX6Solo in C and Eclipse.

    I can able to build the program successfully and download the .elf file to custom board's RAM from the address 0x10000000 for debugging in Eclipse - GDB SEGGER J-Link Debugging.

    However, after halting the debugging and then resuming, I had the problem as "WARNING: Failed to read memory @ address 0x10000000". It seem to be JLink can not access to the system any more. I try newer version of SEGGER J-Link GDB Server but the problem is same.
    The log file is in atteched file.

    Hope that you can help me to proceed this issues. I looking forward to hearing from you.

    Thanks and Best Regards,
    Nguyen.
    Files
  • Hello Nguyen,

    Thank you for your inquiry.
    According to the log file the IDE is telling J-Link to access 0x10000000 which seems not to be possible at that time. It seems that it worked before the error though.
    This indicates that the application that is running in the target device is doing/setting something so the J-Link can't access that memory area anymore.
    It could be some memory read protection, or memory peripheral clock etc.
    So find out what part of your application is causing this and the error will disappear.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    The following contact form can be used for this: Contact Us