[SOLVED] J-Scope - cannot seem to have more than 12 integers. Using J-Link plus

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Scope - cannot seem to have more than 12 integers. Using J-Link plus

    Hello,

    I have an issue with J-scope that has been bugging me for some time. For some reason I cannot get J-Scope to work with more than twelve integers.

    The string we send is "JScope_i4i4i4i4i4i4i4i4i4i4i4i4i4i4" and then build a packet of 14 integers in size. The result in J-scope I can see data coming in but seems to move around as if variables are aliased. In other words, it is reading in only 12 channels and skipping the last two and then showing up on the next read. In other words the variables appear to be jumping around from row-to-row in jscope.

    Attached is an image of J-scope.

    If you can point me in a direction that would be fantastic!

    If you need further information let me know and I will follow up.
    Images
    • Capture.JPG

      194.26 kB, 1,070×1,070, viewed 117 times
  • Hello,

    the channel names for RTT are currently limited to 32 bytes in the J-Link API (max. 31 characters with zero termination).
    Therefore, the last 4 characters of your 35 characters string are cut and only 12 variables are parsed instead of 14.

    We have added the option to use longer channel names to our feature requests. We cannot give you an exact
    schedule about the implementation. But as soon as this is possible, J-Scope will be updated to use it.

    Best regards
    Arne

    PS: Please try the new J-Scope V6.11j beta version, it has some improvements and new features.