[SOLVED] C++, newlib-nano STL, and nRF52

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] C++, newlib-nano STL, and nRF52

    I am attempting to refactor an existing C++ project into Segger Embedded Studio, but STLport does not have all the STL components that I need, so I am trying to get a Segger Embedded Studio project to work with newlib-nano.

    I created a blank project using the nRF C/C++ template and an empty cpp file. When I add “include <vectors>” it will fail since these are not included in STLport. All I should need to do is use the newlib-nano from external ARM GCC libraries. However, so far I have been unsuccessful in using the external STL libraries.

    I am trying to use gcc-arm-none-eabi-7-2017-q4-major and an nRF52832_xxAA processor.

    I have tried changing the standard libraries path, using the external build commands, among other things.

    Does anyone have a walkthrough for adding newlib-nano to a Segger Embedded Studio project or know what settings I may be missing to get the newlib-nano to work with my project?
  • Hello,

    Generally Embedded Studio offers the user to use any standard library they want.
    First disable the use of Embedded Studio standard libraries in project options under Library->Include Standard Libraries->No
    To add your library go to project options Linker->Additional Input Files and add your newlib directory there.
    Now try to rebuild your project and you should be good to go.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    The following contact form can be used for this: Contact Us