[SOLVED] [Ozone] stepping / running interrupt disabled

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] [Ozone] stepping / running interrupt disabled

    I'm using oZone on a J-Link (well euhm... J-Trace to be honest) to debug an nRF52 system running FreeRTOS. I can't really step through the source because FreeRTOS swaps tasks on a timer interrupt and than crashes. Is there a way to disable interrupts from the debugger once it hits a breakpoint?
  • Hello,

    Thank you for your inquiry.
    This is currently not supported in Ozone but is already on our ToDo list and should be implemented within the next couple release versions.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    The following contact form can be used for this: Contact Us