[SOLVED] JLink mini EDU - Cortex not found

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLink mini EDU - Cortex not found

    Hi everyone,

    I have a JLink EDU mini (this one), connected to this breakout board. I am trying to get it to connect to a bluetooth module with the following 4 pins: 3V3, GND, SWDIO, SWCLK.

    For some reason, the uVision IDE says that while the JLink is found, the connected device is not. I have a suspicion as to what's wrong, but not sure. Two questions:

    1) I'm connecting the JLink to the breakout board using this cable, but can't figure out which way the 2x5 attaches to the JLink (it could be connected in two configurations). I tried both and neither work, but if you know that would cut my debugging time in half :)

    2) I'm connecting the following wires:

    Vref on breakout <---> 3V3 on module
    GND on breakout <---> GND on module
    SWIO on breakout <----> SWDIO on module
    CLK on breakout <----> SWCLK on module.

    I think Vref is simply a reference, and the breakout doesn't actually output power. If so, how do I set this circuit up? I think my laptop outputs 5V through USB, but not sure, and it seems like the module runs on 3.3V.

    Any help is much appreciated. Thank you very much for your time!
  • Hello,

    Thank you for your inquiry.
    Sounds like a setup issue with your hardware.

    1) On the J-Link EDU Mini you will see a little "1" engraved next to one of the connector pins. This is pin 1. Align the red flatcable site from the cable you are using with that pin. That is the correct way to attach it to J-Link.

    2) The following Wiki describes common setup mistakes and how to debug them with our tools: wiki.segger.com/J-Link_cannot_connect_to_the_CPU


    I think Vref is simply a reference, and the breakout doesn't actually output power. If so, how do I set this circuit up?


    J-Link EDU Mini does not output power. VTref is the reference voltage that J-Link needs from the target device so J-Link knows how to set up the pin drivers for communication. So your target board needs to be powered separately.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support contact us per e-mail.
    The following contact form can be used for this: Contact Us