[SOLVED] Toolchain - Linker Problem

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Toolchain - Linker Problem

    Hello i am trying to use Linker for nRF52832 Softdevice132. But when i try to compile ,

    Source Code

    1. > /usr/share/segger_embedded_studio_for_arm_3.34/gcc/arm-none-eabi/bin/ld: cannot find -lgcc1> /usr/share/segger_embedded_studio_for_arm_3.34/gcc/arm-none-eabi/bin/ld: cannot find -lc1> /usr/share/segger_embedded_studio_for_arm_3.34/gcc/arm-none-eabi/bin/ld: cannot find -lnosys

    I get these errors. I did not had any problem with the arm gnu toolchain before like this and i've thought it might be software related. I am using 64 bit Linux version of Segger Embedded Studio.

    Also as a side question is there any option to flash my applications hex code with the softdevice to the nRF ?

  • Hi,

    The libraries that you try to link come from the newlib standard library.
    Embedded Studio instead includes its own standard library that is much more optimized for small micros.

    How did you create the project?
    Did you use the Nordic SDK examples?

    The documentation of the Nordic SDK also describes how to flash the softdevice.
    Maybe have a look at it or search the Nordic forums.

    You can specify the softdevice hex as an additional loader file that is loaded with the application on debug start.