[SOLVED] J-Flash command line switch -savedat fails to save data file.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Flash command line switch -savedat fails to save data file.

    Using J-Flash V6.20c (latest as of today). MCU is LPC1788 by NXP. Trying to generate both .cfg and .dat files from a .hex firmware file, using command line. Whereas the -savecfg switch works fine, the -savedat fails. Last line in the log file is "- ERROR: Failed to save data file". The same thing from the GUI works fine. Here is my command line:

    "C:\Program Files (x86)\SEGGER\JLink_V620c\JFlash.exe" -jflashlogTEST.log -openprjTEST.jflash -openTEST.hex -saveprj -savecfgTEST.cfg -savedatTEST.dat

    Any help or suggestion will be greatly appreciated. Thank you guys!
  • Hi,

    thanks for pointing that out.
    This a bug in J-Flash.
    It will be fixed in the next version, planned for release this evening.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.