[SOLVED] J-Flash command line switch -savedat fails to save data file.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Flash command line switch -savedat fails to save data file.

    Using J-Flash V6.20c (latest as of today). MCU is LPC1788 by NXP. Trying to generate both .cfg and .dat files from a .hex firmware file, using command line. Whereas the -savecfg switch works fine, the -savedat fails. Last line in the log file is "- ERROR: Failed to save data file". The same thing from the GUI works fine. Here is my command line:

    "C:\Program Files (x86)\SEGGER\JLink_V620c\JFlash.exe" -jflashlogTEST.log -openprjTEST.jflash -openTEST.hex -saveprj -savecfgTEST.cfg -savedatTEST.dat



    Any help or suggestion will be greatly appreciated. Thank you guys!
  • Hi,


    thanks for pointing that out.
    This a bug in J-Flash.
    It will be fixed in the next version, planned for release this evening.

    Best regards,
    Niklas
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link