[SOLVED] 5.05.10 FLASHER 5 PRO - Error 55 - CRC check in programmer - failed

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] 5.05.10 FLASHER 5 PRO - Error 55 - CRC check in programmer - failed

    Hi there,

    We have a 5.05.10 FLASHER 5 PRO mounted in a test jig of a production programming station that has functioned for the last 2-3 years.

    It now appears to be failing when programming - Error #55 - CRC check in programmer - failed.

    The programmer has always run from a script. But I get the same result when trying to download the programming file from the GUI to the programmer.

    The erase function appears to still erase the target, as a subsequent blank check passes.

    The gui version is still at V2.00x and the flasher FW 2.00m HW 6.00. Has been no need to update, as it worked fine up until now.

    Downloaded the latest gui V2.14b, connected to a different PC, serial cable etc. . This version immediately states "Firmware mismatch" and requests to download the latest version of flasher firmware.

    Going ahead with this, the progress bar gets to 99% and then either get the message, "Communication timed out" or the application crashes.

    I am sort of assuming that something has gone wrong with the on-board flash. If downloading a image file gets a CRC error or trying to update firmware fails...not sure what else it could be.
    Have tried a couple of USB power supplies, and measured 5V on board.

    Is there anything else I can try?

    Thanks in advance.
  • Hello,

    Would it be possible to try to update the firmware of the Flasher 5 PRO as described in the following steps? Thank you.

    - Remove the USB cable.
    - Insert the USB cable while keeping pressed the "Start/Stop" key of the Flasher 5 PRO.
    - Release "Start/Stop" key of the Flasher 5 PRO after the green LED stops blinking.
    - Open the "Computer" window on the Windows PC. The internal persistent storage of the Flasher 5 PRO should be visible in there as removable device.
    - Right-click on the removable device assigned to Flasher 5 PRO and choose "Format..."
    - Make sure that the "Quick Format" option is checked.
    - Press "Start" and wait for the format operation to complete.
    - Copy the attached file to Flasher 5 PRO storage.
    - Remove and reinsert the USB cable.
    - Wait for the red LED of the Flasher 5 PRO to stop blinking.

    Best regards,

  • Hi Marcus.

    Thanks. That restored the unit so that it functions again.

    Are you able to send me the V2.00x version, as I am having some issues with the setup with V2.14b.
    It will also save me a lot of work in re-validating the system if I can get this version re-programmed into the system, using the method you outlined.

  • Hi Marius,

    Have not been able to downgrade the programmer firmware to V2.00x using the same method as restoring it previously to V2.14b that you outlined.

    Have used a srec2bin utility from Keil , and used an offset of (hex) 00110000, to create the binary. (See attached)

    When I try to execute the Flasher software, it displays that it is as 2.14B, and continually loops, requesting to download new firmware, when running the V2.00x version software.

    Is there another way?

  • Hello John,

    Unfortunately there is no other way to update the firmware of the Flasher 5 PRO.

    The firmware image you generated seems to be OK. I was able to downgrade my Flasher 5 PRO from version 2.14b to using it.

    Do you see any activity on the green LED after you plug in the USB cable to perform the firmware update?
    Is the firmware image still present on the internal storage of the Flasher 5 PRO after the firmware update?

    Best regards,