Flasher ARM Not Programming Flash

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Flasher ARM Not Programming Flash

    We have a Flasher ARM that has a problem with programming on chip flash on a LPC2378. Using JFlashARM 4.08 we can connect to the processor but any flash activity is incorrect. If we Erase the device it claims it is ok and a blank check verifies as empty and programming the device reports an error. If we read the device it shows 0xFF in all locations, but this is incorrect as our program still runs and code contents are verified using Crossworks. JMem also shows 0xFF in all locations. We can use Flasher with Crossworks with no problems to program and debug. If we use JMem after Crossworks it shows data in the flash, if we run JFlashARM, erase the chip, go back to JMem it shows 0xFF in all locations. But this is incorrect as the program still runs and Crossworks verifies that code is still in the device. We can program the device using an old black J-Link box using JFlashARM with no problems. We have tried different clocking speeds and different boards each time it gives the same result. We are using the project file that Segger supply for the LPC2378.

    Suggestions?? Thanks.
  • Flasher ARM Not Programming Flash

    Hi sparky0253,

    We have tested this and we do not see any problems.
    Everything works as expected.
    But I am not entirely sure if I understood you correctly.

    What we have done:
    1. Erase the flash of the LPC2378 (on a Keil MCB2300 Eval Board) with J-Flash (V4.08l, latest release version) and "Erase Chip" option.
    2. After that we performed a blank check with J-Flash which reported the flash to be blank.
    3. J-Mem also reports that the flash is blank (showing 0xFF as memory content).
    4. Downloading an application via J-Flash. Both, programming and verifying were okay.
    5. J-Mem also shows the correct data.
    6. Downloading an application via CrossWorks using their flashloader. (By choosing Debug --> Start Debugging (F5)). Everything works as expected.
    7. Read Back via J-Flash and J-Mem reports the correct data.
    8. Erase the flash with J-Flash and "Erase Chip" option.
    9. Blank check reports okay.
    10. Readback with J-Mem & J-Flash reports 0xFF = blank
    11. Choosing Debug --> Verify in CrossWorks reports "verify failed". This is okay, since the flash has been erased via J-Flash.
    12. Debug --> Attach Debugger also does not work since the flash is empty.
    Anything we are missing?

    >>programming the device reports an error
    Could you please post a screenshot which shows the error message?

    Best regards,


    The post was edited 2 times, last by SEGGER- Kai ().