[ABANDONED] iar Jlink and IAR , PC cannot find Iar Jlink

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] iar Jlink and IAR , PC cannot find Iar Jlink

    Hi All, I am a newbie here, I am using a very old IAR Jlink(not segger), 2005 model I think, the s/n 00003716,
    I downloaded and installed segger Jlink software and installed it.
    1. Using windows xp sp3
    2. When I connect the jlink
    via usb to PC and run the jlink utility it cannot find the Jlink on the USB port



    I also tried jlink
    configurator…sees nothing

    3. Installed IAR followed the settings for project options and still cannot communicate to the Jlink
    4, if I remove the USB cable while jlink runs I get "out of synch" messages
    5. Installed Atollic and choose IAR jlink, atollic also canoot find IAR jlink
    6


    Please any ideas? see screenshot attached


    Thanks
    Arnold
    Images
    • Screenshot.jpg

      200.59 kB, 986×567, viewed 383 times
  • hi All

    In addition, I see the Jlink driver in the windows device manager control panel
    I am using latgest IAR EW very 7.80.3
    I also downloaded the latest segger Jlink Software ver 6.12
    when I run Jlink utility it just hangs
    if I remove the usb connection while it is hanging, I get the "failed: cannot connect to Jlink via USB"

    Let me know if anyone can assist please, more screenshots attached :)
    Images
    • Screenshot001.jpg

      91.95 kB, 822×589, viewed 372 times
  • Hi Arnold,


    I just gave it a try, and I could use old versions like a IAR KS J-Link 5.3 or a J-Link ARM 3.0 without any issue with J-Link Commander.
    Could you please give it another try with a different USB-Cable on a different USB-Port without any Hub in-between?
    If the issue persist, could you please give a try on another PC?

    If the then the issue still persists, I can only assume that the J-Link is malfunctioning.
    In this case I would recommend to make use of the SEGGER Trade-In Program .

    Best regards,
    Niklas
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link
  • HI Niklas

    Many Thanks for the reply, where can I find these old versions?, the IAR website does not archive them from what I can see, do you have a link for me please?
    I also tried the different USB cables and a newer laptop with Windows 7 running and a 64 bit machine same issue, The interesting part is that the LED on th unit rapidly flashes until it find the driver then stays on which means it has found some driver hence it would still just rapidly blink if it did not find a driver.

    I suspect it needs an old driver to get it to work initially if I can do this then I can surely upgrade it

    Thanks for the help
    Kind Regards
    Arnold
  • Hi Arnold,

    sorry if my statement was not precise enough:
    "IAR KS J-Link 5.3" and "J-Link ARM 3.0" are old hardware versions, not software versions.
    I only used the newest software version with these two old hardware units, and it worked fine.

    Best regards,
    Niklas
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link