[ABANDONED] "Active read protected STM32 device" message with new STM32H743 using J-Trace V6.12f

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] "Active read protected STM32 device" message with new STM32H743 using J-Trace V6.12f

    Hello all,
    some time ago I had the same problem with STM32F7 and J_Trace V5.10g. This was solved, see post
    [SOLVED] "Active read protected STM32 device" message after upgrading J-Trace to V5.10g

    Now I got the this error again while trying to debug code for the new STM32H743.
    - Marcus


    JLink info:
    ------------
    DLL: V6.12f, compiled Jan 13 2017 16:37:50
    Firmware: J-Trace Cortex-M Rev.3 compiled Dec 15 2016 14:46:47
    Hardware: V3.10
    S/N : 203200722
  • Hi Marcus,


    thanks for your inquiry. I am little curious why this issue is occurring as we are yet to implement detection of secured STM32H7 devices, therefore as long as the correct device is selected, this dialog should not show up in the current version.
    We plan to release a version that supports detection of secured STM32H7 devices by the end of this week.

    I will keep you posted.


    Best regards,
    Niklas
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link