[ABANDONED] Unable to update Segger JLink PRO

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Unable to update Segger JLink PRO

    Hello,

    I have a segger JLink PRO and every time I tried to connect to a target I got the message for performing a firmware update.
    I click on Yes, then the update process completes and after firmware update windows closes, the window hangs and become unresponsible (in Jflash).
    I have also tried to update in JLinkConfig.exe, I select the device, click on update firmware, the process completes OK but the program doesn't respond. The same behavior.

    In J-Link Commander:

    Source Code

    1. SEGGER J-Link Commander V6.12e (Compiled Jan 6 2017 17:20:00)
    2. DLL version V6.12e, compiled Jan 6 2017 17:19:29
    3. Connecting to J-Link via USB...Updating firmware: J-Link Pro V4 compiled Dec 23 2016 12:00:11
    4. Replacing firmware: J-Link Pro V4 compiled Oct 8 2015 09:29:10
    5. Waiting for new firmware to boot
    6. FAILED: Communication timed out: Requested 4 bytes, received 0 bytes !
    7. Could not read J-Link capabilities.
    8. J-Link>

    The device is locked and I need to unplug and plug to be accessible, but at the connection time I got the firmware update message again. This happens always.

    Thanks,
  • Hi,


    sorry to hear that you experience issues with J-Link Pro.
    Does the J-Link work normally when skipping the firmware update offer?
    Could you please try to update the firmware from a different computer with a different USB-cable which is plugged directly into the PC without any USB-Hub between?


    Best regards,
    Niklas

    PS: I edited your post slightly because sth. went wrong during the formatting.
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link