[SOLVED] J-Link problems with Keil v3.85

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link problems with Keil v3.85

    I just bought a J-LINK and downloaded the eval version of Keil MDK v3.85. Flash loading with J-LINK always fails with:

    No Algorithm found for: 00000000H - 00002C57H (insert your address here)

    The J-LINK works fine with CrossWorks & IAR, and KEIL works fine with ULINK, so I don't think it's faulty HW.

    Any input appreciated.

    Thanks - Chip

    Here's the log output:

    Build target 'MCB2140'
    assembling Startup.s...
    compiling DiskImg.c...
    compiling usbhw.c...
    compiling usbcore.c...
    compiling usbdesc.c...
    compiling usbuser.c...
    compiling mscuser.c...
    compiling memory.c...
    linking...
    Program Size: Code=6936 RO-data=4356 RW-data=60 ZI-data=17780
    ".\Obj\Memory.axf" - 0 Error(s), 0 Warning(s).
    Load "C:\\Keil\\ARM\\Boards\\Keil\\MCB2140\\USBMem\\Obj\\Memory.AXF"
    VTarget = 3.248V
    Info: TotalIRLen = 4, IRPrint = 0x01
    Info: TotalIRLen = 4, IRPrint = 0x01
    Info: RTCK reaction time is approx. 126ns
    Info: Auto JTAG speed: Adaptive
    DLL version V4.05i, compiled May 18 2009 19:20:52
    Firmware: J-Link ARM V8 compiled Jun 30 2009 11:00:16
    Hardware: V8.00
    Hardware-Breakpoints: 2
    Software-Breakpoints: 2048
    Watchpoints: 0
    Found 1 JTAG device, Total IRLen = 4:
    Id of device #0: 0x4F1F0F0F
    ARM7 identified.
    Using adaptive clocking instead of fixed JTAG speed.
    Info: TotalIRLen = 4, IRPrint = 0x01
    Info: TotalIRLen = 4, IRPrint = 0x01
    JTAG speed: 1000 kHz
    No Algorithm found for: 00000000H - 00002C57H
    Erase skipped!

    Here's the Keil info:


    IDE-Version:
    µVision3 V3.85
    Copyright (c) Keil Elektronik GmbH / Keil Software, Inc. 1995 - 2009

    Tool Version Numbers:
    Toolchain: RealView MDK-ARM Version: 3.70
    Toolchain Path: BIN40\
    C Compiler: Armcc.Exe V4.0.0.524 [Evaluation]
    Assembler: Armasm.Exe V4.0.0.524 [Evaluation]
    Linker/Locator: ArmLink.Exe V4.0.0.524 [Evaluation]
    Librarian: ArmAr.Exe V4.0.0.524 [Evaluation]
    Hex Converter: FromElf.Exe V4.0.0.524 [Evaluation]
    CPU DLL: SARM.DLL V3.70
    Dialog DLL: DARMP.DLL V1.45
    Target DLL: Segger\JLTAgdi.dll V???
    Dialog DLL: TARMP.DLL V1.45
  • Hello chipslice,

    >>No Algorithm found for: 00000000H - 00002C57H
    >>Erase skipped!

    This lines indicated that you are trying to program the flash memory
    and no flashloader is selected.

    If you have a license for FlashDL (flashloader of J-Link) simply go
    to Project -> Options -> Utilities and disable the "Update Target before Debugging" checkbox,
    select the correct device in the "Device" tab (in the uVision)

    If you want to use the Keil flashloader, you have to enable the "Update Target before Debugging" checkbox and click the Settings button. (See EnableKeilFlashloader.gif)
    Then click the "Add" button and select the correct flashloader for your device (See SelectFlashloader.gif)

    Now click the "OK" button and start your debug session.
    Now you should be back in business

    Best regards
    Alex
    Images
    • EnableKeilFlashloader.gif

      8.55 kB, 630×461, viewed 2,214 times
    • SelectFlashloader.gif

      7.33 kB, 582×347, viewed 2,537 times