Jlink GDB Server with Atmel's AT91R40008 with yagarto eclipse

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Jlink GDB Server with Atmel's AT91R40008 with yagarto eclipse

    I'm using the yagarto eclipse environment with 3.79h beta. My startup commandfile for the debbuger is
    target remote localhost:2331

    monitor reset
    monitor sleep 500
    monitor writeu32 0xFFE00000 = 0x1000213D
    monitor writeu32 0xFFE00004 = 0x20003E3D
    monitor writeu32 0xFFE00020 = 0x00000001
    monitor writeu32 0xFFE00000
    monitor writeu32 0xFFE00004

    monitor speed auto
    break main
    load
    [img]http://www.segger2.com/file:///C:/DOKUME%7E1/WIEGEL%7E1.AD-/LOKALE%7E1/Temp/moz-screenshot.jpg[/img][img]http://www.segger2.com/file:///C:/DOKUME%7E1/WIEGEL%7E1.AD-/LOKALE%7E1/Temp/moz-screenshot-1.jpg[/img]
    I can load my software, but im unable to stop the cpu or run to a breakpoint. The GDB Server shows only:
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D300 8)
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D3008)
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D3008)
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D3008)
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D3008)
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D3008)
    Read 4 bytes @ address 0x000097AC (Data = 0xE59D3008)
    Debugger terminated connection !
    No, no emotiocons it is an eight and a ) . Dammned automatic.
    After a minutes the debugger is terminating the connection.
    Thank you in advance

    Best regards Jörg