JLink (V6.00g, deb) Error: Could not connect to target

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • JLink (V6.00g, deb) Error: Could not connect to target

    Dear all,

    I could not connect my STM32F103ZE board and STM32F407VG Discovery board via Segger J-Link Plus (EDU version) on Ubuntu 14.04.5 LTS, while I can happily debug other boards on WIndows 7. ?(

    Jlink Software packs I used are both of the latest version V6.00g.

    Source Code

    1. $ JLinkGDBServer -device STM32F103ZE -if SWD -speed 1000


    Source Code

    1. SEGGER J-Link GDB Server V6.00g Command Line Version
    2. JLinkARM.dll V6.00g (DLL compiled Aug 17 2016 13:20:32)
    3. -----GDB Server start settings-----
    4. GDBInit file: none
    5. GDB Server Listening port: 2331
    6. SWO raw output listening port: 2332
    7. Terminal I/O port: 2333
    8. Accept remote connection: yes
    9. Generate logfile: off
    10. Verify download: off
    11. Init regs on start: off
    12. Silent mode: off
    13. Single run mode: off
    14. Target connection timeout: 0 ms
    15. ------J-Link related settings------
    16. J-Link Host interface: USB
    17. J-Link script: none
    18. J-Link settings file: none
    19. ------Target related settings------
    20. Target device: STM32F103ZE
    21. Target interface: SWD
    22. Target interface speed: 1000kHz
    23. Target endian: little
    24. Connecting to J-Link...
    25. J-Link is connected.
    26. Firmware: J-Link V9 compiled Aug 17 2016 11:20:49
    27. Hardware: V9.30
    28. S/N: 269306079
    29. OEM: SEGGER-EDU
    30. Feature(s): FlashBP, GDB
    31. Checking target voltage...
    32. Target voltage: 3.28 V
    33. Listening on TCP/IP port 2331
    34. Connecting to target...ERROR: STM32: Connecting to CPU via connect under reset failed.
    35. ERROR: STM32: Connecting to CPU via connect under reset failed.
    36. ERROR: Could not connect to target.
    37. Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...
    38. Shutting down...
    39. Could not connect to target.
    40. Please check power, connection and settings.
    Display All


    Thank you and Best regards,
    Honig
  • STM32F407VG Discovery Board

    Source Code

    1. $ JLinkGDBServer -device STM32F407VG -if SWD


    Source Code

    1. SEGGER J-Link GDB Server V6.00g Command Line Version
    2. JLinkARM.dll V6.00g (DLL compiled Aug 17 2016 13:20:32)
    3. -----GDB Server start settings-----
    4. GDBInit file: none
    5. GDB Server Listening port: 2331
    6. SWO raw output listening port: 2332
    7. Terminal I/O port: 2333
    8. Accept remote connection: yes
    9. Generate logfile: off
    10. Verify download: off
    11. Init regs on start: off
    12. Silent mode: off
    13. Single run mode: off
    14. Target connection timeout: 0 ms
    15. ------J-Link related settings------
    16. J-Link Host interface: USB
    17. J-Link script: none
    18. J-Link settings file: none
    19. ------Target related settings------
    20. Target device: STM32F407VG
    21. Target interface: SWD
    22. Target interface speed: 1000kHz
    23. Target endian: little
    24. Connecting to J-Link...
    25. J-Link is connected.
    26. Firmware: J-Link V9 compiled Aug 17 2016 11:20:49
    27. Hardware: V9.30
    28. S/N: 269306079
    29. OEM: SEGGER-EDU
    30. Feature(s): FlashBP, GDB
    31. Checking target voltage...
    32. Target voltage: 3.29 V
    33. Listening on TCP/IP port 2331
    34. Connecting to target...Connected to target
    35. Waiting for GDB connection...
    Display All


    still Waiting ... for over 30 min.

    Thank you and Best regards,
    Honig
  • Dear all,

    Downloaded (V512j, .deb) , remove V600g and install this older version.

    STM32F4Disc Board connected successful, step into Debug perspective in Eclipse.

    STM32F103 still not work, the same error message as before:

    Source Code

    1. ERROR: STM32: Connecting to CPU via connect under reset failed.
    2. ERROR: STM32: Connecting to CPU via connect under reset failed.
    3. ERROR: Could not connect to target.
  • Hi,

    We are not aware of any issues with ST STM32F4 or ST STM32F1 series devices.
    According to your latest update, you are up and running with the ST STM32F4 board, correct?

    Regarding ST STM32F103:
    Do you use a custom hardware or an evaluation board? In latter case, which one?
    Can you please give it a try using the latest version V6.12? The version is available for download here: segger.com/downloads/jlink
    Please follow the instructions from the following troubleshoot article: wiki.segger.com/J-Link_can%27t…the_CPU#Target_connection
    If you run into any issues, please provide us the screenshot of the entire J-Link Commander output.


    Best regards
    Niklas
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link