Interrupts not firing?

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Interrupts not firing?

    Hello all;

    I am currently using emUSB (CDC device profile) along with embOS successfully in a project, targeting Atmel's AT91SAM7S256. Now, I wish to add a bootloader/firmware update application that will take a hex file from a PC via USB in order to update the firmware. I wish to again use emUSB (CDC), however without an OS this time.

    In the emUSB manual, on page 14 it states that emUSB can be used with or without an RTOS. However, on page 21, it states that a real-time kernel is required. Isn't this conflicting?

    I've tried to use the USB_OS_NONE interface with no success - it seems as though I'm not getting any interrupts. I've put a breakpoint on the assembly code located at 0x18 - I can see this is being hit from the firmware (the Timer interrupt for embOS), but not my bootload application. My intent was to have logic located at this location to call the appropriate interrupt handler function - either that of embOS or emUSB - but I'm not even getting that far. Shouldn't the emUSB driver take care of ensuring all required interrupts are enabled? If so, is there some interrupt vector remapping that I must be doing when switching between apps?

    Thanks for any advice,

  • EP0 interrupt?

    One further question:

    I have a sample app that seems to be working OK (i.e., interrupts are firing) without an OS. However, I am never seeing the EP0 interrupt - what would cause this? I seem to be getting the BusReset interrupt, followed by a Suspend interrupt.

  • Please be aware that this forum is intended for customers which want to get help by other customers (e.g. they are not longer in support). We have of course also every day a look in this forum but the better way to get support is to get directly in contact with us by phone or email. Then you can be sure that you get really fast support (normaly at working time within an hour).

    But your are right, the embOS part of this forum is pretty quiet. This is caused that embOS is much reliable and easy to use (that is what I hear very often from our customers).
    To make your decision easier please download the embOS trial version for SH2A and HEW. If you like to evaluate also our other products please visit Segger - SH2A and download there the complete Segger Eval software package.

    With the embOS trial version you can evaulate embOS perfectly because the trial version has no functional limitation. So you really know what you get when you buy embOS.

    If you have any other questions please do not hesitate to contact us directly.

  • Thanks for the reply. I did download it and I'm actually making pretty good (and quick) progress with it. This tells me you have tried using your own demos before posting them!

    I also realize there will be some trouble down the road and what I'm trying to ascertain is the response of not only the company, but the community as well. If I run into some problem when you're closed, it's nice to know there is an active community which will read my issue and possibly offer suggestions to a solution.

  • To be honestly I do not think that most customers work with forums because they prefer to contact us directly. Therefore you will not find much embOS related technical discusssions in forums.

    Anyhow even on not working time we check our emails and you can be pretty sure that you get in urgent cases response asap.