[SOLVED] AM3352 DBGEN is not asserted error

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] AM3352 DBGEN is not asserted error

    I'm using a J-Link Pro to debug a AM3352 based board. Sometimes when I try to connect from CodeBench I get an error that tells me that since DBGEN is not asserted, no debugging is possible. Once the board is in this condition, I can't force it out of it. Complete power cycling, changing to another J-Link Pro, etc doesn't seem to make a difference. Then suddenly (after multiple hours) it will start working again and I can emulate. I tried the script that is mentioned in http://forum.segger.com/index.php?page=Thread&postID=3166&highlight=DBGEN#post3166 but that didn't work even after I updated the script to cater for the different ID's returned by the AM3352.

    Any suggestions what to do next?

    This is what the result is of an attempt to connect to the target with jlink.exe looks like:-



    C:\Program Files (x86)\SEGGER\JLink_V512e>jlink
    SEGGER J-Link Commander V5.12e (Compiled Apr 29 2016 15:04:36)
    DLL version V5.12e, compiled Apr 29 2016 15:03:58


    Connecting to J-Link via USB...O.K.
    Firmware: J-Link Pro V4 compiled Mar 29 2016 18:47:17
    Hardware version: V4.00
    S/N: 174301807
    License(s): RDI, FlashBP, FlashDL, JFlash, GDB
    IP-Addr: DHCP (no addr. received yet)
    VTref = 3.348V




    Type "connect" to establish a target connection, '?' for help
    J-Link>connect
    Please specify device / core. <Default>: AM3352
    Type '?' for selection dialog
    Device>
    Please specify target interface:
    J) JTAG (Default)
    S) SWD
    TIF>
    Device position in JTAG chain (IRPre,DRPre) <Default>: -1,-1 => Auto-detect
    JTAGConf>
    Specify target interface speed [kHz]. <Default>: 4000 kHz
    Speed>
    Device "AM3352" selected.




    Could not measure total IR len. TDO is constant high.
    TotalIRLen = 6, IRPrint = 0x01
    TotalIRLen = 10, IRPrint = 0x0011
    CoreSight AP[0]: 0x04770001, AHB-AP
    CoreSight AP[1]: 0x04770002, APB-AP
    CoreSight AP[2]: 0x04760000, JTAG-AP
    Found Cortex-A8 r3p2
    6 code breakpoints, 2 data breakpoints
    Debug architecture ARMv7.0
    TotalIRLen = 6, IRPrint = 0x01
    TotalIRLen = 10, IRPrint = 0x0011


    ****** Error: Cortex-A/R (connect): Core internal signal DBGEN is not asserted. Debugging is not possible.
    TotalIRLen = 6, IRPrint = 0x01
    TotalIRLen = 10, IRPrint = 0x0011
    TotalIRLen = 6, IRPrint = 0x01
    TotalIRLen = 10, IRPrint = 0x0011
    Can not connect to target.
    J-Link>
    Kind Regards,
    Vinny
  • Hi Vinny,


    I answered your mail regarding this issue.

    Best regards,
    Niklas
    Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
    Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
    Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
    Notification for Embedded Studio: Link