[SOLVED] SystemView on Linux

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SystemView on Linux


    I wanted to test SystemView (with freeRTOS) on Linux. I tried to get the "SystemView for Linux, DEB Installer 64-bit version" and "SystemView for Linux, TGZ archive 64-bit version". But both seem not to work on my system. I can start the SystemView executable without any problems, but when I press the record button the programs exists with the following message:

    Could not open library: libjlinkarm.so.5 (Resource temporarily unavailable). Exiting now.

    I also tried the 32-bit version with lib32 packages. Now, a configuration windows appears when I press record. I used the following settings: Connection to J-Link:USB; Target Device:MK64FN1M0VLL12; Target Interface and speed; JTAG 2000kHz; RTT Control Block Detection: Address 0x1fff0c44

    Since Autodetection and Search Range didn't work I figured that using the correct address might do the trick - but it didn't help. Once I hit "OK" I get the message "Failed to start recording. Could not connect." I made sure that the target was connected and running and thatSEGGER_SYSVIEW_Conf() that was called at the start of the application.

    Do you guys have an idea what the problem might be? Any help is greatly appreciated.

  • Thanks for your reply. I changed the LD_LIBRARY_PATH to the location of libjlinkarm.so.5. But I still get the same error:
    "Could not open library: libjlinkarm.so.5 (Resource temporarily unavailable). Exiting now."
    I also checked with

    C Source Code

    1. echo $LD_LIBRARY_PATH
    if the path were changed to the location of libjlinkarm (which it was). I wonder why I don't get the error with the 32-bit version of SystemView... But with the 32-bit version I wasn't able to connect to the target as I mentioned before. I'm not really sure why this is happening.

    Many thanks!