EmWin Simulation with Visual Studio 2015

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • EmWin Simulation with Visual Studio 2015

    I am struggling to open and successfully compile the EmWin Simulator with Visual Studio 2015 community edition. It would be nice if anyone who uses VS2015 for running the simulator provide some pointers.

    Thanks in advance

    Cheers
    AF
  • Hello,

    You are right. Unfortunately, there is a Problem if Visual Studio 2015 is used.
    But we have found a solution for this issue.

    Change the Project Properties as followed:

    1. Right-Click on the Project (e.g. SimulationTrial) -> Properties
    2 Set Configuration to "All Configurations"
    3. Goto Configuration Properties -> Linker -> Input.
    4. Set Ignore All Default Libraries: "No"
    5. Set Ignore Specific Default Libraries: "LIBC.lib;LIBCMTD.lib"
    6. Goto Configuration Properties -> Linker -> Advanced
    7. Set Image Has Safe Exception Handlers:"No (/SAFESEH:NO)"
    8. Click "OK"-Button.

    Best regards,
    Thorsten
  • I just tried to translate the current version of SimulationTrial in VisualStudio 2015 Update 3 with a modified configuration as described above.
    Unfortunately, the linker still reports 4 errors

    Error LNK2019 unresolved external symbol _sprintf referenced in function __WndProcSysInfo@16 SimulationTrial D:\7\emwin\GUISim.lib(SIM_GUI_App.OBJ) 1
    Error LNK2001 unresolved external symbol _sprintf SimulationTrial D:\7\emwin\GUISim.lib(LCDSIM.OBJ) 1
    Error LNK2001 unresolved external symbol _sprintf SimulationTrial D:\7\emwin\GUISim.lib(SIM_GUI_Log.OBJ) 1
    Error LNK1120 1 unresolved externals SimulationTrial D:\7\emwin\Exe\GUISimulationDebug.exe 1

    Any idea how to solve this problém?