event objects behavior

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • event objects behavior

    Hello

    I experienced the following behavior of event objects in embOS V4.04a.1:
    I have an event object controlling a task's behavior. In the task's main flow I was waiting for the object with the OS_EVENT_Wait() function while in an ISR the OS_EVENT_Pulse function was called. Everything worked fine with this setup. For safety reasons I added a timeout to the task's waiting behavior calling OS_EVENT_WaitTimed() instead of OS_EVENT_Wait(). With this change, I ended up in the timeout, even though the pulse function was called as it was before and clearly within the timeout.

    Changing the ISR function call from OS_EVENT_Pulse() to a OS_EVENT_Set() brings back the wanted functionality. My question: is it known and wanted, that OS_EVENT_Wait() and OS_EVENT_WaitTimed don't behave the same to the OS_EVENT_Pulse() call?


    I am running in the default mode (OS_EVENT_RESET_MODE_SEMIAUTO).

    Thanks and best regards,
    Severin
  • Hi Severin,

    I just checked it but I was not able to reproduce your issue.
    Everything works as expected.
    Anyway I would suggest to use OS_EVENT_RESET_MODE_AUTO or OS_EVENT_RESET_MODE_MANUAL instead of OS_EVENT_RESET_MODE_SEMIAUTO which is still there to be comatible with older embOS versions.

    If you still having problems please feel free to send us more details or even a simple project which shows the probelm.

    Best regards,
    Til