USBH Stopped to work

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • USBH Stopped to work

    Hello,

    I´m currently back to working on USB Host firmware, after to perform the initalizations according user guide so:

    - call USBH_Init();
    - install usbh task and isr
    - call FS_Init();
    - call USBH_MSD_Init()

    Then I try to plug a flash drive in USB connector and set a breakpoint on device insertion callback function, but the program don´t reach here, apparently the code is the same, I´m using the BSP supplied by segger.

    What I am missing to get the USB Host to work?

    Regards.

    Felipe
  • Yan, thanks for response, I fixed up the problem.

    Two issues was causing, the first the my USB Hal was not correctly configured. Second, I out application we use two devices on file system, and the other device (the SDCard) used the same AHB memory bank of USB, causing corruption of both devices file system. So the solution was create a memory pool used by SDCard Hal in a region outside of USB AHB RAM and now all is working fine.

    Thanks again for help.

    Felipe
  • uLipe wrote:

    Yan, thanks for response, I fixed up the problem.

    Two issues was causing, the first the my USB Hal was not correctly configured. Second, I out application we use two devices on file system, and the other device (the SDCard) used the same AHB memory bank of USB, causing corruption of both devices file system. So the solution was create a memory pool used by SDCard Hal in a region outside of USB AHB RAM and now all is working fine.

    Thanks again for help.

    Felipe
    Ah, I see.
    Glad to hear that you could resolve this.

    Regards,

    Yan