Problem with connecting J-Flash to core

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Problem with connecting J-Flash to core

    Hi!

    Im Using an J-Link EDU for flashing an Atmel SAM3X8E. Im using Atmel Studio to write my code and flash it as well, no problem so far. Now I wanted to program it using another PC and tried using J-Flash since it is already included into the J-Link Driver.
    When I click connect, it takes some time and then I get the following Error message:

    Source Code

    1. - Connecting via USB to J-Link device 0
    2. - J-Link firmware: V1.20 (J-Link ARM V8 compiled Sep 22 2014 23:26:43)
    3. - Target interface speed: 2000 kHz (Auto)
    4. - Initializing CPU core (Init sequence) ...
    5. - Initialized successfully
    6. - Target interface speed: 2000 kHz (Auto)
    7. - Reading CFI info ...
    8. - Could not find CFI compliant flash device
    9. - Detecting flash memory ...
    10. - ERROR: Could not find any flash devices
    11. - ERROR: Failed to connect
    Display All


    This is the same error I get on my main computer where I can flash my device using atmel Studio. Im using SWD.
    Am I doing something wrong? Also, Is there a MAC tool available? Right now Im using Virtualbox which is a hassle to flash my chips.

    Thanks in advance!
  • Hi,

    I assume you are trying to program the internal flash of your SAM3X8.
    If yes: Your J-Flash is *not* configured correctly.
    You have to select the correct device in J-Flash (as you have to do in Atmel Studio as well...)
    Sample project attached.

    For Mac / Linux:
    J-Flash is currently not available under these platforms but you can also program the internal flash via J-Link Commander:
    segger.com/jlink-flash-download.html#DevelopmentPurposes


    - Alex
    Files
    • ATSAM3X8E.zip

      (923 Byte, downloaded 305 times, last: )