[SOLVED] Eclipse gdb debugging

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Eclipse gdb debugging

    I'm trying to set up a J-Link for debugging from Eclipse via the gdb server. When Eclipse launches the debugger it connects to the gdb server and flashes the code, but Eclipse doesn't show any debug information (registers, source, etc.) in the IDE windows. However, I can type gdb commands into the Eclipse debugger command window and everything works as expected. From the command window I can step through my code, set breakpoints, see variables and registers, and the gdb client even shows the correct source lines--but only in the command window, not the IDE windows.

    I do see a message in the J-Link GDB Server window indicating "WARNING: Unknown packet received: "qXfer:threads:read::0,fff". Does anyone know the implications of this? Could it be related the the problem I'm having? Is anyone else seeing this?

    I see the same behavior running on both Windows 7 and Fedora 20 Linux, and on two separate PCs. I've also tried a couple of different Arm toolchains, and all behave the same.

    I'm using:

    Eclipse Kepler SP2 (4.3.2) w/CDT 8.3.0 (current versions, downloaded last week)
    J-Link GDB Server V4.86
    Arm Cortex-M0 (Cypress PSoC 4245)
    Toolchain from
    launchpad.net/gcc-arm-embedded
    GNU ARM Eclipse plugins from gnuarmeclipse.livius.net/blog/

    I've also tried the toolchain from Cypress PSoc Creator 3.1 and get the same results.

    Web searches suggest that lots of people are successfully using Eclipse and the J-Link for ARM development and debugging, so I expect this is a simple case of operator error or misconfiguration, but I've had a heck of a time trying to figure it out. Hence my plea to the users of this forum for any help or advice you might care to give.

    Thanks,
    - Larry

    The post was edited 1 time, last by Larry ().

  • GDB client protocol error

    New info:

    The gdb client shows this:

    170,714 31-list-thread-groups
    170,718 31^error,msg="Protocol error: qXfer:threads:read (threads) conflicting enabled responses."

    This seems to suggest a disconnect between the protocol handling between the gdb client and the J-Link gdb server.

    Is anyone successfully using the J-Link gdb server with the gnu arm plugin (or others)? If so, can you share your version numbers so I can try to match?

    - Larry