OS crash

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • I am getting a message that my OS task ends unexpectedly. I'm looking for some insight as to what typically causes these types of errors. I have looked at the stack to see if have consumed more RAM than allocated, EWARM does not indicate a problem there. I have tried commenting out the tasks I have created, and it still crashes. I have also tried commenting out all the startup code, but

    OS_IncDI(); /* Initially disable interrupts */
    OS_InitKern(); /* Initialize OS */
    OS_InitHW(); /* Initialize Hardware for OS */

    and the crash still happends. My project has been running for quite a while, and its an intermittent failure not a hard failure. Any insight would be appreciated.

    Digging in a little deeper, it seems like the task crash happens when I execute the code OS_SwitchFromInt. If I set a breakpoint on that line, the processor halts. If I set a breakpoint on the following line, the task crashes. all this code is in OS_StartASM...

    The post was edited 1 time, last by robiwan ().

  • Hello Harsh,

    although your company is out of support for several yeasrs please contact the embOS support directly per email if you think this problem is caused by embOS.
    I will send you a private message with the support email address (which can be also found in the embOS manual)

    Best regards,