BUG: STM32 Brick? J-Link cannot recover! STLINK can!

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • BUG: STM32 Brick? J-Link cannot recover! STLINK can!


    i have now the second board with a STM32F373VC and J-Flash says following:

    Brainfuck Source Code

    1. Application log started
    2. - J-Flash ARM V4.72 (J-Flash compiled Jun 12 2013 15:47:39)
    3. - JLinkARM.dll V4.72 (DLL compiled Jun 12 2013 15:47:08)
    4. Reading flash device list [C:\Program Files (x86)\SEGGER\JLinkARM_V472\ETC\JFlash\Flash.csv] ...
    5. - List of flash devices read successfully (1941 Devices)
    6. Reading MCU device list [C:\Program Files (x86)\SEGGER\JLinkARM_V472\ETC\JFlash\MCU.csv] ...
    7. - List of MCU devices read successfully (2729 Devices)
    8. Opening project file [-------removed--------------] ...
    9. - Project opened successfully
    10. Opening data file [-----removed-----] ...
    11. - Data file opened successfully (262144 bytes, 1 range, CRC = 0xCC061A40)
    12. Programming and verifying target (262144 bytes, 1 range) ...
    13. - Connecting ...
    14. - Connected successfully
    15. - RAM tested O.K.
    16. - ERROR: PC of target system has unexpected value after blank checking. (PC = 0x200000EA)!
    17. ---------------------------------------------------------------------- Registers -------------------------------------------------------------------------------------
    18. PC = 200000EA
    19. Current: R0 = 00007BA0, R1 = 08000000, R2 = 00008000, R3 = FFFFFFFF
    20. R4 = 20000000, R5 = 00007B9C, R6 = 000000FF, R7 = 2000014F
    21. ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    22. - ERROR: Failed to program and verify target
    23. Disconnecting ...
    24. - Disconnected
    Display All

    Atollic TrueStudio is also not working with this board and J-Link.

    In a Chinese Forum i found this hint: "STLINK can make this good"

    And it really helps!
    After using the STLINK, the J-Link also works fine again.

    I think the J-Link didn't correctly reset, erase or unsecure the chip.

    Best Regards
  • Hi,

    First of all, it would help if you could specify *what* exactly you are doing if you are expecting us to help you here...
    From your description it sounds that it does not happen on all boards but only on some because you wrote:
    i have now the second board [...]

    Are you actually securing the device?
    are you writing the option bytes of the device?
    Can you provide the image you are programming to the STM32 device?

    Best regards
  • I wanted to flash the new Software on these boards (from the production line), but i got this error message.
    Only chip erase was working.
    It tried to unsecure with the "J-Link STM32 unlock" Tool, but i didn't help.

    The STLINK shows me that the Chip has Read Out Protection had Level 1.
    I switched with STLINK to level 0 and all was working fine again with the J-Link.

    Sorry, i cannot provide you the image file. (The image file doesn't secure the chip)

    I have only one print left with this error.
  • I had the same problem with an STM32F417 micro, and the STM32 Unlock procedure did not work.
    I solved it by discharging the extrnal battery coin attached to RTC peripheral. After this, the unlock procedure work, and i can use the jlink to dowload the firmware.
  • J-Link STM32 Unlock not working for STM32F373

    The "J-Link STM32 Unlock" is not working for the STM32F373VC.
    When i lock the STM32F373 with the software or with the ST-Link Tool, i cannot unlock it with the "J-Link STM32 Unlock" Tool.
    Can you fix that?